CRITICALCVSS 10.0EPSS 0.27CVE-2026-97229CI/CD
Your patched GitLab may still be open to a full server takeover
Anyone who can reach a self-hosted GitLab server can take it over with one booby-trapped pipeline file, and attackers are already trying.
GitLab shipped a fix on 12 Oct. The catch is where the bug lives: not in GitLab's own code but in Ruby, the language GitLab is written in, and the fix only comes inside GitLab's official packages. A server that runs GitLab on its own copy of Ruby is still open after the update, until Ruby is updated too. CISA, the US government's cyber agency, confirmed on 29 Oct that the bug is being used in attacks.
Alpine Linux found this out on its own server. On 20 and 21 Oct an attacker with a newly registered account sent crafted CI configurations to gitlab.alpinelinux.org, crashed its workers 8 times and got partway through the exploit 4 times. Alpine upgraded to 19.3.6 on 22 Oct and found on 26 Oct that it was still vulnerable, because its image used standard Ruby. It found no evidence that the attacker's code ran, could not rule it out, and rebuilt the server from scratch: every password, 2FA enrolment, access token and CI/CD variable value was reset.
Source: GitLab advisory, 12 Oct · Ruby advisory, 23 Oct · Alpine incident report, 28 Oct · CISA KEV, 29 Oct · Patched 19.4.2, 12 Oct
#More this week
CRITICALCVSS 9.8EPSS 0.99CVE-2026-109618CVE-2026-109619RUNTIME
Two exploited PHP flaws allow unauthenticated code execution
PHP 8.5.12, 8.4.27, 8.3.36 and 8.2.35, released 21 Oct, fix two flaws the PHP team says allow unauthenticated remote code execution: request memory left uninitialised after an out-of-memory abort (CVE-2026-109618), and global state left pointing into freed request memory (CVE-2026-109619). CISA added both to its exploited list on 26 Oct. Its entry for the Linux kernel flaw CVE-2026-46300, added 28 Oct, says the three chain to implant PHP webshells and run commands as root. NVD scores the pair 9.8 and 8.1; PHP scores both 9.2 under CVSS 4.0.
- [ ]Upgrade PHP to the latest release of your version, or install your distribution's patched package
- [ ]Patch the Linux kernel on the same servers
Source: PHP release announcements, 21 Oct · CISA KEV, 26 and 28 Oct · Patched 8.5.12, 21 Oct
HIGHCVSS 8.6EPSS 0.01CVE-2026-76418FIREWALL
Cisco firewalls with secondary authentication can be crashed from the internet
A crafted request to the SSL VPN login reloads Cisco ASA and FTD firewalls when any tunnel group, DefaultWEBVPNGroup included, has secondary authentication configured. The attacker needs no account and no successful VPN login. Cisco published fixed releases for every train on 28 Oct, and CISA added the flaw to its exploited list a day later. There is no workaround, only a mitigation: turn secondary authentication off. To see whether a firewall is exposed, run these on it; if the second shows any secondary-auth line, it is.
show run webvpn
show run all tunnel-group | i tunnel-group|secondary-auth
- [ ]Upgrade to the fixed release for your train, using the Software Checker linked in the advisory
- [ ]Until then, turn off secondary authentication
Source: Cisco advisory cisco-sa-asaftd-tunnel-dos-s6mgkb75, 28 Oct · CISA KEV, 29 Oct · Patched per train, 28 Oct
INFOSUPPLY CHAIN
A poisoned LiteLLM release stole credentials for under two hours
On 21 Oct, LiteLLM's release pipeline published litellm==1.107.0 to PyPI from 11:39 to 13:23 UTC, and pointed the v1.107.0, latest, main-latest and main-stable image tags on Docker Hub and GHCR at compromised images from 11:46 UTC until as late as 14:20 UTC. The release carried compiled malware that steals credentials and loads remote-code-execution tools; the source tag is clean. LiteLLM says the attacker held the GitHub CLI tokens of three developers, used an organisation owner's token to disable branch protection, and pointed the release workflow at a lookalike repository. There is no CVSS score because this is a compromised release, not a flaw in the code, so the chip says INFO.
# Do not start Python on a suspect host: cook.pth runs first
$ find / -path '*-packages/*' \( -name cook.pth \
-o -name cook.py -o -name sitecustomize.py \) 2>/dev/null
$ ls -l /tmp/remote_code_loader.lock
- [ ]If a machine ever installed
1.107.0, treat it as compromised: rebuild it and change every key and password it held - [ ]Pin LiteLLM to
1.106.2 until the project says otherwise
Source: LiteLLM incident report, 21 Oct, updated 30 Oct